Condor 2 scenery creation notes (rev 4)
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?’s — John Murtari, john@murtari.org

Background & Credits:

I didn’t know where to start. Plenty of advice from Nick Bonniere, a Condor2
pro who created landscape for Lake Placid. He supplied the below numbered lists of
tips which were useful in understanding the process. Also great tutorial from Luis
Briones (a member of a Flying Club in Argentina) on how to create photo realistic
scenery easily (no 3-D trees/buildings, but the ground looks real from the air).

1) a scenery is a made up of a group of tiles

2) each tile is 23 km x 23 km (14 mi x 14 mi), which is actually a resolution of 90
meters times 256 = 23.040 km

If you pick 4 tiles, I would suggest you offset the airport from the center a bit
so it falls fully into one of the 4 tiles, otherwise it will be cut-up into 4
pieces. Not absolutely necessary, just a suggestion so you can view the airport in
one tile only.

3) the original resolution of 90 m is based on Space Shuttle elevation data (STRM)

4) Condor-2 uses a resolution of 30 meters, which is 3 times the resolution of
Condor-1, and 30m STRM data is available

5) The last 1/4 tile edge of a scenery is not flyable. So if you have one tile,
only the centre 1/2 or 11.5 km x 11.5 km is flyable, If you use 2 x 2 tiles, i.e 4
tiles, 46 km x 46 km, only the centre 34 km x 34 km is flyable, etc...

6) the projection used is UTM, (Universal Transverse Mercator), This means that all
elevation data and photographic data needs to be converted to UTM coordinates. If
you pick 4 tiles, I would suggest you offset the airport from the center a bit so
it falls fully into one of the 4 tiles, otherwise it will be cut-up into 4 pieces.
Not absolutely necessary, just a suggestion so you can view the airport in one tile
only.

Tiles are in a grid of rows and columns starting at the bottom right corner (South
East), which is tile 0000. The first two digits are the column number and the
second two digits are the row number. Above tile 0000.bmp is tile 0001l.bmp. The
tile to the left is tile 0100.bmp

You can use multiple resolutions. For LakePlacid, the centre tile is hi-res
8192x8192, while all the other tiles are 4096x4096. The one I sent you was
4096x4096. The file size increases by a factor of 4, so I only sent you a 48MB
file instead of 192MB.
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The steps to create a Condor scenery are as follows:

1) pick an a range of coordinates you want to be able to use

2) expand that area by at least 1/4 tile or 6 km all around.

3) pick the nearest number of tiles that will accommodate the coordinate range
desired - for a flyable 20 mi x 20 mi, which is 32 km x 32 km, you could use just 4
tiles or that could be expanded to 2 x 3 or 3 x 2 or 3 x 3 tiles.

4) Get the STRM elevation data, convert to UTM and crop to the desired number of
tiles

5) Import this data using the Condor tool and you can then create a basic scenery

Well, the general idea is to avoid multiple UTM zone landscapes if you don't know
what you are doing. Regarding older QGis versions - the guide was written when
2.18.16 was the stable release and everything worked. So the easiest option may be
to download this version.

Here is the link to the main folder with all older versions, just pick your
platform: http://download.osgeo.org/ggis/ JM - I used 2.18.16

6) add an airport and you can then actually fly over the scenery, but it will be
just grey.

7) get images for the area and convert to UTM and crop to each tile

8) create a forest map : this can be done manually with the condor tool or a
graphics program but is extremely tedious, or use geo data that may be available.

9) create a thermal map : this can be done manually or use geo data and assign
thermal values to each type of feature, such as roads, lakes, bogs, green fields,
yellow fields, dark fields, etc...

10) add details, such as more airports, turn-points, a wind sock for each airport,
and various objects if desired, such as hangars and other airport features. This
can take a lot of effort.

GOAL: Test the concepts for a simple scenery.

Image processing takes time. Start with just one tile of our local area and see if we can go through the
steps and at least a simple terrain. We’ll worry about trees, lakes, buildings later.... Start with our
airport at Dansville, NY.

STEP ZERO: Download tools, get the landscape creation guide.

I downloaded the tool set and documentation for landscapes from the condorsoaring.com site,

unpacked that in a different directory from where Condor?2 is installed.
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STEP ONE: Determine the coordinates for the scenery

Used this tool to find our UTM and map distances —
https://mangomap.com/robertyoung/maps/69585/what-utm-zone-am-i-in-#
Appolachian Mountains  Mount Morris
Perrly

See first map below, each segment from Dansville is 7 miles, forms one 14x14 square
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D
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Short Tragt
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Our initial test run will just be that one square, need the LAT LON for each corner.
Upper left :  42.670492 -77.850838  Upperright: 42.670492  -77.581329
Lower left:  42.469991 -77.850838  Lowerright: 42.469991  -77.581329
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STEP TWO: convert to UTM coordinates, proper size.

I used the UTMtools (part of the scenery download from Condor site), I put in the numbers above in
the “Set are of interest” button.

UTMtools 1.0.6621.26976 _ 0 %

Temain import wizard |~ Coordinate conversion  About

Decimal latitude & longitude | UTM Prerequisite checks
Set area of TLlattude: 42 570452 TLeasting: (18M) 266387 056612375 Single UTM zone: 0K
bi;tﬁsfw TlLlongtude: -77.850838 TLrnorthing:  (18N) 4728165.43645538 Same hemisphere: OK
coordinates |  BRIatitude:  42.469991 BReasting: (18N) 287754.333527367 1“”‘ rwer 16t mezician: DK
BR longtude: 77581329 BRnothing: (18N) 4705183 70212385 Whole tile dimensions:

Calculate scenery parameters

I was not on an even tile (expected). I then clicked on “Calculate scenery parameters” and
then in the “Scenery parameters”, I adjust to just 1x1 tile. It gave me new calibration numbers to try
for LAT/LON to try. I also saved the calibration points John/soaring/condor/calibration.csv

Upper/Top Left: 42.6704880449693 -77.8508389980393
Lower/Bottom Right: 42.4698542971003 -77.5614644066829

Temain import wizard  Coordinate conversion  About
Decimal latitude & longitude UTM Prerequisite checks
Set area of TL latitude: 42 670452 TLeasting:  (18M) 266387 096612375 Single UTM zone: OK
b';’tuﬁj:tw TLlongtude: -77.850838 TLnorthing:  (18N) 4728165.43645598 Same hemisphere: OK
coordinates |  BRIstitude: 42 469591 BReasting: (18N) 287794 333927367 :‘:}”"h ”l"e_: 1:_”"“ mendian: - OK
BR longitude: -77.581329 BR northing: (18N) 4705189.70212385 Whole tle dmensions:
Calculate scenery parameters
Scenery parameters Scenery size in tiles from boundary coordinates:  0.92512326380880889 « 0 9972222222203322
Tiles -easting: 1[5 UTM zone: 18N TLnothing: 4728165

Tiles - northing: |1

Ak

Change zone

Calculated calibration points
Top left lat lon

|42 670488044 |-77.85083890¢| | TLeasting: 266387 BReasting: 289427
Bottom left lat lon

|42.463251456| |-77.84141048¢|
Top right lat lon

|42.677138680| |-77.56996661(|
Bottom right _ |at lan Save calibration BR nortthing: 4705125

|42.469854297| |-77.56146440€] points CSV

Scenery dmensions: 2304 km x 23.04 km
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I then tried “Set area of Interest” again with the new numbers, and it PASSED!!!

ITMtools 1.0.6621.26976 B 0

Temain import wizard  Coordinate conversion  About

Decimal latitude & longitude UTM Prerequisite checks
Sv._a‘t area of TL latitude:  42.6704380445653 TLeasting: (18N) 266386.55535755 Single UTM zane: OK
interest TL lengitude:  -77.8508389980353 | TLnorthing:  (18N) 4728164 5333976 Same hemisphere: OK

boundarny
coordinates BR latitude:  42.4698542571003 BR easting:  (18M) 285426 995958591

BR longitude:  -77.5614644066823 | BR northing: (18N) 4705124 55339866

Mot over 180th merdian: OK
Whaole tile dimensions: OK

Calculate sceneny parameters

You need to store the all these values for later, 23040 23040 42.6704880449693 -77.8508389980393
keep the image! TL — top left, BR — bottom right. 0 23040 42.6771386808413 -77.5699666101818
0 0 42.4698542971003 -77.5614644066829

This gets used when you want to lay a photo
23040 0 42.4632514561498 -77.8414104892785

layer on top (later).

You also need the UTM:

TL easting: 266386.99999759 northing: 4728164.9999976
BR easting: 289426.99999591 northing: 4705124.99999866

STEP THREE: Get the terrain data

Used USGS survey — https://earthexplorer.usgs.gov/.

Registered and then entered the search criteria. | entered the complete numbers above, they were truncated.

1. Lat:42.6705, Lon:-77.8508 r x
2. Lat:42.6771, Lon:-77.5700 b 4 x
Munda
3. Lat:42.4699, Lon:-77.5615 4 x
4, Lat:42.4633, Lon:-77.8414 b 4 x

Add Coordinate | Clear Coordinates
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(FROM Condor Landscape Guide revla.pdf,) Now that we have outlined the area of interest, we
can proceed with getting the data. Press the Data Sets >> button, from the list on the following page select
Digital Elevation > SRTM > SRTM 1 Arc-Second Global and finally press the Results >> button

Then | chose download, BIL 1 arc-second and saved to john/soaring/condor/n42_w078 1larc_v3_bil.zip

Unzipped the files and got four files.

STEP FOUR: process with qgis

After reading some FORUM notes, I downloaded and installed QGIS 2.18.16, x64 from —
http://download.osgeo.org/qgis/

I started QGIS, now following instructor in Condor Landscape Guide revla.pdf, page 15. Follow
those instructions carefully, can be confusing and mistakes are costly!

The picture below is from the last clipping, it was a bit of a mystery the 1 (x,y) and 2(x,y)
blocks. But simple 1 (TL), 2 (BR), x (easting), y (northing) values from earlier....

NOTE!! When creating the clip the tutorial narrative leaves out that you have to add ‘tr 30
30’ in the window as earlier. It does show in their example screen, but not in the narrative.

Page 7


http://download.osgeo.org/qgis/

é Clipper ?

R

e

Input file {raster)

[’soaring,’condorﬁﬁsc 1_warped.bil | b l Select...

Output file [:uhnfsoaring_-"condnrfﬂsc 1_dipped.bil l Select...
[] Mo data value [D I%]
—Clipping mode
’@ Extent ) Mask layer J
Select the extent by drag on canvas
or chanage the extent coordinates
x | 266396.99999759 | x | 289426.99999591 ]
i | 2
v [4728164.9999976 ] v [4705124,99999886 |

% Load into canvas when finished

gdal_translate -projwin 266386,999998 47281565.0 289426.999996
| 4705125.0 -of EHdr -t 30 30

C:fJohn/soaring/condor /flzc1_warped.bil
| C:fJohnfsoaringfcondor fflsc1_dipped. hil

[
©]

Raster Database Web

PRLLPLPHPP MBI
ke B =0ES

Processing  Help

abc|
T

abc

[+

abc

abc

Idm iv? s |

From the Importing terrain elevation data into condor, the header of our files looks like this:

BYTEORDER I

LAYOUT BIL

NROWS 768 << - confirms we are one tile 768, even divide by 192 -yes!
NCOLS 768

NBANDS 1

NBITS 16

BANDROWBYTES 1536
TOTALROWBYTES 1536

PIXELTYPE SIGNEDINT

ULXMAP 266401.999861111
ULYMAP 4728150.00013889
XDIM 30

YDIM 30

We can directly import into condor, 768 even divide by 192. 'We DO NOT need to use the
RawToTrn tool for additional cropping... But we do need to Load/Save as they specify.
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E Condor Landscape Toolkit 2: RAW to TRMN

Load ]Crup Sawe l .

LTk zane
e =[N

Select cormer
* Topleft

" Top right
" Bottam left

" Bottorn right

Cormer coordinates
LT easting
|EEESBE.99999?59

LT northing
|4?281E4.99999?E|

Sawve to TRN |

Cropped: 763 x 768
Cropped: 23 kmx 23 km

After the “Save to TRN” as they instructed you will find the following in
/Condor2/Landscapes/flsc1/flscl (just a file)

/Condor2/Landscapes/flsc1/HeightMaps (a bunch of .tr3 files)
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STEP FIVE: Building the Terran ONLY Landscape

Again, just following the exact instructions in the guide.

Had an immediate problem, my new Landscape showed in the pop down menu in the Editor, but
nothing happened when selected? I checked other landscapes, they worked.

Found the problem, I looked in the directory for my landscape and the file I had saved was just called
flsc1, not flscl.trn — I renamed it and things were fine.

After I added our airport, looked like this:

ﬂ Condor Landscape Toolkit 2: Landscape Editor 5 C
File View Tools About

Landscape

ffisct ~] [sereen: z4ss0m
L '

Yiewihodify

[ Ground ohjects

[ Height map

[ Calibration points
[ Farest maps

[ Thermal ma,
© T

Dansville (KDSY)
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STEP SIX: Try it out in Condor2

I started Condor2 and my landscape didn’t show as an option?? I then checked the directories for
existing landscapes and found I was missing a .ini file.

I created flsc1.ini by just copying one of the others.
Started Condor again and my landscape was there!!!!
Also, got a warning about demo mode, unregistered scenery?

When I selected it I got a missing .cup file error, and that was FATAL, very FATAL, had to kill
Condor2 with the task manager (kept getting an access violation error).

So I just copied an existing cup into my Lanscape directory and renamed it to flsc1.cup.

Started condor and it looked like a desert, but our local terrain was visible!!!

STEP SEVEN: Adding photo realistic scenery.

The 3-d work takes some time. Wanted to have quick steps to give us ground that would look
somewhat correct from an airborne perspective.

Resources:

Convert decimal lat/lon to hh:min:sec — https://www.latlong.net/lat-long-dms.html

Up/Top Left: 42.6704880449693 (42° 40' 13.7568" N) -77.8508389980393 (77° 51' 3.0204" W)
LowBot Right: 42.4698542971003 (42° 28' 11.4744" N) -77.5614644066829 (77° 33' 41.2704" W)

STEPS BELOW taken from Tutorial by Luis Briones (a member of a Flying Club in Argentina) -
http://aeroroca.com.ar/varios/Easy%20way%20t0%20making%20a%20photo-realistic%20Condor
%20scenery.pdf

Below is from Section II and III of his tutorial (above). Section 1 covers basic steps we already
completed above.

NOTE: remarks you see [between braces] are additional comments I added.
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Get the image data.

Needed utilities:

- SASPlanet (https://bitbucket.org/sas_team/sas.planet.bin/downloads/)

1. Open SASPlanet (download your satellite images)
[ I chose Bing Maps as a source ]

a) Go to menu Operations->Selection Manager->By Coordinates
[ You can enter in decimal format ]

b) Find area a bigger than the final map. Not too much
c) Put upper and lower corner and push Apply.
d) Select Download tab.

e) Select Map/Overlay layer
[Bing]
f) Select zoom. 17 is good (1.87m/pixel at 39°S 68°W). Check if there are images for this
zoom before start.
[/ chose 18]

g) Check Split selection to, parts*:
[ This will allow for simultaneous downloads, the files can be very large |

h) Choose the biggest number your system allows.
i) Push Start. This take time, depend of the level of zoom that you choose. Always check the

method with low details zoom, like 10 or less. You need a lot of free disk space. 60 Gb or so.
[ I chose zoom 18, and with just a 14x14 mile selection, it downloaded 4 30 Meg files

2. When step one is over
a) Go to menu Operations ->Selection Manager->Last Selection or load from file
b) Select Stitch tab.
¢) In Output format, select GeoTiff.

d) Put your path and file name in the Save to:
[ Make sure to choose name prefixes different than you used for the original terrain files
earlier |

e) Select your Map: [ Bing |

f) Choose your zoom. (The same that you use in step one)
g) Put No in Overlay layer:

h) Import. Select EPSG:4326 in Projection.

i) Click Start. This process makes the image you use in Condor. Be patient!!!
[ | have a pretty fast core7 processor/SSD drive, took about 2 minutes ]

| split my 10x14 tiles scenery in 4x8 images. In Stitch tab, you can divide the image using Row and Column
in bottom right part of it. [ I only used one image ]|

Created a large tif file (over 1 gig) —» 1,4973,49,961 -- pflscl.tif
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b)

Orthophotographic HD image data

Needed utilities:

- QGIS - Free, open source Geospatial Information System (GIS) software.

http://www?2.qgis.org/en/site/
- GIMP2.8.4+ (http://www.gimp.org/downloads/) or Photoshop.

1. Open QGIS

a) Go to menu Layer ->Add Layer->Add raster layer... and select the file(s) from step 2.

Go to menu Layer ->Add Layer->Add delimited text layer... and select the CalibrationPoints.csv. First

record has field names unchecked and Geometry definition is Point coordinates. Choose field 4 for X field and field 3

for Y Field.
Click OK.

[ When in Part 111, calibration, used the calibration.csv created earlier, added column heading:

ab,yx]

a b y X
23040 23040 42.6704880449693 -77.8508389980393
0 23040 42.6771386808413 -77.5699666101818
0 0 42.4698542971003 -77.5614644066829
23040 0 42.4632514561498 -77.8414104892785

a) Select WGS84 EPSG:4326 and Click OK.
[ You may see another option with your UTM zone from earlier, DO NOT PICK it]

b) Check if your image is bigger than the calibration points.
[ Mine was slightly smaller on two corners, but seemed OK to use]

Go to menu Raster->Miscellaneous->Build virtual raster (Catalog).

a) Check Choose input directory instead of files.
[ This should be the same where you saved the .tiff ]

b) Select the directory. It will take a few seconds, then a whole bunch of files will show up in
the lower section of the dialog box.

c) Use Select to choose the path and name (.vrt) of your Output file.
[ | chose pflsc1_raster |

d) Uncheck Load into Canvas when finished.

e) Select the pencil and delete all files name except one.
[ In the bottom area you will all the files in the directory. You must remove almost all of
them shown dfter the ddalbuildcrt command. Just leave your tiff file(s).
In my case this was left:
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gdalbuildvrt C:/John/soaring/condor/plfcl raster.vrt C:\John\
soaring\condor/pflscl.tif

f) Delete the actual file name and insert a wildcard. E.g. D:\imagenes\Tutorial/* tif
[ | didn’t do this, only 1 file ]

g) Click Ok.
[ It now created the .vrt file |

h) Click Close when the process finished.

3. Go to menu Raster->Projections->Warp (Reproject).

a) In Input File, choose the vrt file you just built in step 2.c.
[pflsc1_raster.vrt]

b) Use Select to choose the path and name (.vrt) of your Output file. E.g. Reproj.vrt
[ / chose pflsc1_reproj , make sure to pick .vrt extension ]|
c) Check that Source SRS is EPSG:4326

d) Check Target SRS and choose the UTM zone for you.
[ Now pick your UTM zone ]

e) Click Resampling method and choose Cubic Spline.

f) Click Memory used for caching. If you have it, input 500mb. Above 500mb, the speed is not
supposed to be appreciably faster.
[ I used 500 mb ]

g) Click Use multithreaded warping implementation if you have more than one core in your
processor.

h) Uncheck Load into canvas when finished.

i) Click OK and be patient!!!
[ Not sure about that comment, mine finished very quickly, and created the pfisc1 _reproj
file |

k) Click Close when the process finished.

4. Go to menu Project-> Project Properties
a) Click Enable ‘on the fly’ CRS transformation (OTF).
b) Select your UTM reference system.
c) Click OK.

5. Go to menu Raster->Extraction->Clipper...

a) Select the file from step 3.b in Input file (raster).
[pflsc1_reproj.vrt in my case]

b) Use Select to choose the path and name of your Output file. Ex: Clipped.vrt
[pflsc1_clipped.vrt — again, choose correct extension |

¢) In Clipping mode check Extend.

d) Go to the upper left calibration point and zoom a lot near there.

e) Click at point and maintain. Move a bit to lower right the mouse.
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)
k)
)
m)

n)

Write somewhere the values of 1 X)Y.
Go to the lower right and do the same. In this case move the mouse to upper left and
write de values of 2 X,Y.

Put the values of point f) and g) in 1 XY and 2 X,Y
[#1 is TOP LEFT, x (easting), y(northing), #2 is bottom right |

You see a red rectangle that cover your calibrations points.
[ I was a little bit outside, not sure if that mattered — seemed to be a problem later
I went back and used click/drag for a square entirely inside image]

Click Load into canvas when finished.

Select the pencil and delete “-of ADRG”. (if present)
Click OK.

Click Close when the process finished.

Deselect other images in Layers Panel (Left side)
If all worked ok, the last image has exactly the size of your calibrations points. EUREKA!!!

6. Right click in Layers Panel over the name of the image from step 5.b
[ in my case pfisc1_clipper, little confusing on left pane layers panel, the only one that showed
picture was pfisc1 (not the clipped ]

a)
b)

c)
d)

f)
g
h)

)

k)

Select Save As...

Select Rendered image in Output Mode.

Click Create VRT and leave Format to GTiff.

Use Browse to choose the path and name of directory that you use in Save as. You can
create there.

[ You will need to create a directory to store the output file(s), in my case pfisc1_clipped]
Verify that in CRS to you have selected your UTM zone.

Uncheck Add saved file to map. No change to Extent.

In “Resolution (current: layer)“ click Columns.

Put the number of tiles that have your scenery multiplied for your resolution. For example, if
scenery has 10 tiles in east-west direction and 14 in north-south. In low resolution scenery,
choose 1024 to test the method. 10x1024 = 10240 (left input->Columns) 14x1024 =14336 (right
input—Rows)

[ In my case there was only 1 tile for flsc1, wanted hi res. | chose (1 * 8192), have to be multiples

of 1024]

In VRT Tiles put the resolution that you desire.
[In my case 8192]

Click OK. When this process is done, you have a lot of tiles. Only need convert tiff to
BMP and rename files to import to Condor.

[ THIS did take several minutes, be patient |

You can close QGIS... (might want to save project)

[ The final output was two files in the pflsc1_clipped directory, A BIG TIFF
268,501,380 - pfiscl_clipped.0.tif
2698 - pflscl_clipped.vrt

Page 15



7. Open Gimp or Photoshop to convert Tiff to BMP

[I used GIMP, very simple, free download]

There are many way to convert tiff to BMP. | prefer patch way. There are many
examples in web. One of this is https://www.youtube.com/watch?v=Tlaca4T9hQs
If you prefer you can touch color too.

Another way is using a program like BulkimageConverter

[ Got some warnings when opening in GIMP, but looked okay, out of bounds checkerboxes
near some corners

8. Using your imagination to rename file. | left some clues in Appendix | . Search about .bat files.

First time | made 5x14 scenery, one by one, by hand, using F2 in explorer

9. Move all tiles to \Condor2\Landscapes\Scenery _name\Working\Terragen\Textures directory
[ Just one tile, rename to 0000.bmp ]

10. Open Landscape Editor

O T QO
~— ~— ~—~ ~—~ ~—~

o

h)

Select SceneryName from drop down menu
Tools -> Import tile size textures

File -> Export flightplanner map

File -> Export forest map

File -> Export thermal map
File — Export the forest and terrain hashes

File -> Export textures to DDS (this may take several hours)
[ When asked for non-existing, say NO — recreate everything, took a few minutes]
Tools -> Check for missing files

Save landscape and take a Condor test flight on your new photo-realistic scenery :0)
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FINISHING TOUCHES....

After the landscape is created, you can zip up the landscape directory, but you can leave out “Working”
to save a lot of space:

0 Airports/

0 Images/
1.2m HeightMaps/
4.1M ForestMaps/
43Mm Textures/

465M working/

Adding the Dansville Airport, make sure to convert feet to meters, e.g
660 elevation = 200 meters

3500’ runway = 1066 meters

100’ width = 30 meters

Also discovered the actual runway heading is 312 to line up in condor.
Had located airport using this LAT/LON : 42.570530/-77.713272

It was showing about 50’ offset to right of 32, wanted to move it into grass on right of the 32,

about 150 feet.
Changed LON to: -77.712502
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APPENDIX ON PHOTO CONVERSION created by Luis Briones

The below is needed for large sceneries, more than 1 tile. In the test flsc scenery I created only 1 tile
and the .bmp was called 0000.bmp.

Gets more complicated with more tiles!

Appendix |
QGIS named files from zero using the name of directory where you put. E.g. test.0.tif, test.1.tif, ...
Row Columns
2 3 4 5 6 7 8 9 10
1 0 1 2 3 4 5 6 7 8 9
2 10 11 12 13 14 15 16 17 18 19
3 20 21 22 23 24 25 26 27 28 29
4 30 31 32 33 34 35 36 37 38 39
5 40 41 42 43 44 45 46 47 48 49
6 50 51 52 53 54 55 56 57 58 59
7 60 61 62 63 64 65 66 67 68 69
8 70 71 72 73 74 75 76 77 78 79
9 80 81 82 83 84 85 86 87 88 89
10 90 91 92 93 94 95 96 97 98 99
11 100 101 102 103 104 105 106 107 108 109
12 110 11 112 113 114 115 116 117 118 119
13 120 121 122 123 124 125 126 127 128 129
14 130 131 132 133 134 135 136 137 138 139
In the table before you can see the order lof the files to made my 10 x 14 sc¢enery.

Condor use other order as you can see in the following table:

Slice9 | Slice 8 | Slice7 | Slice 6 | Slice 5 | Slice4 | Slice 3 | Slice2 | Slice1 | Slice 0
0913 0813 0713 | 0613 0513 0413 0313 | 0213 0113 0013
0912 0812 0712 | 0612 0512 0412 0312 0212 0112 0012
0911 0811 0711 0611 0511 0411 0311 0211 0111 0011
0910 0810 0710 | 0610 0510 0410 0310 0210 0110 0010
0909 0809 0709 | 0609 0509 0409 0309 0209 | 0109 | 0009
0908 0808 0708 | 0608 0508 0408 0308 | 0208 | 0108 | 0008
0907 0807 0707 | 0607 0507 0407 0307 | 0207 | 0107 | 0007
0906 | 0806 | 0706 | 0606 0506 0406 | 0306 | 0206 | 0106 | 0006
0905 | 0805 | 0705 | 0605 0505 0405 | 0305 | 0205 | 0105 | 0005
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0904 0804 0704 0604 0504 0404 0304 0204 0104 0004
0903 0803 0703 0603 0503 0403 0303 0203 0103 0003
0902 0802 0702 0602 0502 0402 0302 0202 0102 0002
0901 0801 0701 0601 0501 0401 0301 0201 0101 0001
0900 0800 0700 0600 0500 0400 0300 0200 0100 0000
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With some work, | can make an excel table like this follow Tom Berry’s spreadsheet method:

Desired scene
1 | size in terragen

2 Width Height ‘

3 10 14
7 ColY | Row x| Condor QGIS Order
1 1 0913 test.0 | copy test.0.bmp ..\FinalBMP\0913.bmp
1 2 0912 | test.10 | copy test.10.bmp ..\FinalBMP\0912.bmp
10 1 3 0911 test.20 | copy test.20.bmp ..\FinalBMP\0911.bmp
11 1 4 0910 | test.30 | copy test.30.bmp ..\FinalBMP\0910.bmp
12 1 5 0909 | test.40 | copy test.40.bmp ..\FinalBMP\0909.bmp

10 1 0003 | test.109 | copy test.109.bmp ..\FinalBMP\0003.bmp

10 12 0002 | test.119 | copy test.119.bmp ..\FinalBMP\0002.bmp

10 13 0001 | test.129 | copy test.129.bmp ..\FinalBMP\0001.bmp

10 14 0000 | test.139 | copy test.139.bmp ..\FinalBMP\0000.bmp

| put the values of Col and Row by hand using copy and paste. To made the other
thing | used the concatenate order. First time that | use it.

https://support.office.com/en-us/article/ CONCATENATE-function-8f8ae884-2ca8-
4f7a-b093-75d702bea31d

Condor Value:
=CONCATENATE(0,$A$3-A8,IF($B$3-B8> 9,$B$3-B8,CONCATENATE(0,$B$3-B8)))

QGIS Value:
=CONCATENATE($F$3,".",(B8-1)*10+(A8-1))

Order Value:
=CONCATENATE("copy ",D8,".bmp"," ..",$F$1,"\",C8,".bmp")

$F$1 = test
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